summaryrefslogtreecommitdiff
path: root/compiler/tflchef/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/tflchef/CMakeLists.txt')
-rw-r--r--compiler/tflchef/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/compiler/tflchef/CMakeLists.txt b/compiler/tflchef/CMakeLists.txt
new file mode 100644
index 000000000..71c5e2ab1
--- /dev/null
+++ b/compiler/tflchef/CMakeLists.txt
@@ -0,0 +1,19 @@
+nnas_find_package(Protobuf QUIET)
+
+if(NOT Protobuf_FOUND)
+ return()
+endif(NOT Protobuf_FOUND)
+
+if(NOT TARGET mio_tflite)
+ return()
+endif(NOT TARGET mio_tflite)
+
+# Recipe Parser
+add_subdirectory(proto)
+# Core Library
+add_subdirectory(core)
+# TFlite Library
+add_subdirectory(tflite)
+# Tools
+add_subdirectory(tools)
+add_subdirectory(tests)