summaryrefslogtreecommitdiff
path: root/compiler/tfl-verify/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/tfl-verify/CMakeLists.txt')
-rw-r--r--compiler/tfl-verify/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/compiler/tfl-verify/CMakeLists.txt b/compiler/tfl-verify/CMakeLists.txt
new file mode 100644
index 000000000..a368b2930
--- /dev/null
+++ b/compiler/tfl-verify/CMakeLists.txt
@@ -0,0 +1,12 @@
+if(NOT TARGET mio_tflite)
+ return()
+endif(NOT TARGET mio_tflite)
+
+file(GLOB_RECURSE SOURCES "src/*.cpp")
+
+add_executable(tfl-verify ${SOURCES})
+target_include_directories(tfl-verify PRIVATE src)
+target_link_libraries(tfl-verify mio_tflite)
+target_link_libraries(tfl-verify safemain)
+target_link_libraries(tfl-verify cwrap)
+target_link_libraries(tfl-verify stdex)