summaryrefslogtreecommitdiff
path: root/compiler/tfinfo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/tfinfo/CMakeLists.txt')
-rw-r--r--compiler/tfinfo/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/compiler/tfinfo/CMakeLists.txt b/compiler/tfinfo/CMakeLists.txt
new file mode 100644
index 000000000..678912e6f
--- /dev/null
+++ b/compiler/tfinfo/CMakeLists.txt
@@ -0,0 +1,20 @@
+file(GLOB_RECURSE SOURCES "src/*.cpp")
+file(GLOB_RECURSE TESTS "src/*.test.cpp")
+list(REMOVE_ITEM SOURCES ${TESTS})
+
+add_library(tfinfo STATIC ${SOURCES})
+set_target_properties(tfinfo PROPERTIES POSITION_INDEPENDENT_CODE ON)
+target_include_directories(tfinfo PUBLIC include)
+target_link_libraries(tfinfo stdex angkor oops)
+
+# TODO Remove "nnkit_support_tftestinfo" later
+add_library(nnkit_support_tftestinfo ALIAS tfinfo)
+
+if(NOT ENABLE_TEST)
+ return()
+endif(NOT ENABLE_TEST)
+
+nnas_find_package(GTest REQUIRED)
+
+GTest_AddTest(tfinfo_test ${TESTS})
+target_link_libraries(tfinfo_test tfinfo)