summaryrefslogtreecommitdiff
path: root/compiler/souschef/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/souschef/CMakeLists.txt')
-rw-r--r--compiler/souschef/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/compiler/souschef/CMakeLists.txt b/compiler/souschef/CMakeLists.txt
index 5a307be16..ca7eddc6f 100644
--- a/compiler/souschef/CMakeLists.txt
+++ b/compiler/souschef/CMakeLists.txt
@@ -1,5 +1,13 @@
+nnas_find_package(Protobuf QUIET)
+
+if(NOT Protobuf_FOUND)
+ message(STATUS "Build souschef: FAILED (missing Protobuf")
+ return()
+endif(NOT Protobuf_FOUND)
+
file(GLOB_RECURSE SOURCES "src/*.cpp")
add_library(souschef STATIC ${SOURCES})
set_target_properties(souschef PROPERTIES POSITION_INDEPENDENT_CODE ON)
target_include_directories(souschef PUBLIC include)
+target_link_libraries(souschef PUBLIC libprotobuf)