summaryrefslogtreecommitdiff
path: root/compiler/pepper-str/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/pepper-str/CMakeLists.txt')
-rw-r--r--compiler/pepper-str/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/compiler/pepper-str/CMakeLists.txt b/compiler/pepper-str/CMakeLists.txt
index cbe01b86a..481073af7 100644
--- a/compiler/pepper-str/CMakeLists.txt
+++ b/compiler/pepper-str/CMakeLists.txt
@@ -1,5 +1,6 @@
add_library(pepper_str INTERFACE)
target_include_directories(pepper_str INTERFACE include)
+target_link_libraries(pepper_str INTERFACE nncc_coverage)
if(NOT ENABLE_TEST)
return()
@@ -8,5 +9,5 @@ endif(NOT ENABLE_TEST)
# Google Test is mandatory for test
nnas_find_package(GTest REQUIRED)
-GTest_AddTest(pepper_str_test test.cpp)
+GTest_AddTest(pepper_str_test src/pepper-str.test.cpp)
target_link_libraries(pepper_str_test pepper_str)