summaryrefslogtreecommitdiff
path: root/compiler/nnc/tests/soft_backend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/nnc/tests/soft_backend/CMakeLists.txt')
-rw-r--r--compiler/nnc/tests/soft_backend/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/compiler/nnc/tests/soft_backend/CMakeLists.txt b/compiler/nnc/tests/soft_backend/CMakeLists.txt
new file mode 100644
index 000000000..5526327ba
--- /dev/null
+++ b/compiler/nnc/tests/soft_backend/CMakeLists.txt
@@ -0,0 +1,9 @@
+file(GLOB_RECURSE SOFT_TEST_DEF_SOURCES *.def)
+
+nnc_make_generated_sources("${SOFT_TEST_DEF_SOURCES}" ${CMAKE_CURRENT_BINARY_DIR} SOFT_TEST_GENERATED_SOURCES)
+
+add_executable(nnc_system_soft_backend_cpp_compile CompileCPP.cpp ${SOFT_TEST_GENERATED_SOURCES})
+target_link_libraries(nnc_system_soft_backend_cpp_compile PRIVATE soft_backend_cpp mir)
+target_include_directories(nnc_system_soft_backend_cpp_compile PRIVATE ${CMAKE_CURRENT_BINARY_DIR} ${NNC_SOFT_BACKEND_DIR})
+
+add_test(nnc_system_test_soft_backend_cpp_compile nnc_system_soft_backend_cpp_compile)