summaryrefslogtreecommitdiff
path: root/compiler/moco-log/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/moco-log/CMakeLists.txt')
-rw-r--r--compiler/moco-log/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/compiler/moco-log/CMakeLists.txt b/compiler/moco-log/CMakeLists.txt
new file mode 100644
index 000000000..036b4e74b
--- /dev/null
+++ b/compiler/moco-log/CMakeLists.txt
@@ -0,0 +1,9 @@
+# TODO Find how to test logging framework
+file(GLOB_RECURSE SOURCES "src/*.cpp")
+
+add_library(moco_log SHARED ${SOURCES})
+target_include_directories(moco_log PUBLIC include)
+target_link_libraries(moco_log PUBLIC hermes)
+target_link_libraries(moco_log PRIVATE hermes_std)
+target_link_libraries(moco_log PRIVATE stdex)
+install(TARGETS moco_log DESTINATION lib)