summaryrefslogtreecommitdiff
path: root/compiler/luci/env/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/luci/env/CMakeLists.txt')
-rw-r--r--compiler/luci/env/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/compiler/luci/env/CMakeLists.txt b/compiler/luci/env/CMakeLists.txt
index 3d8387a47..7025db2e8 100644
--- a/compiler/luci/env/CMakeLists.txt
+++ b/compiler/luci/env/CMakeLists.txt
@@ -2,10 +2,16 @@ file(GLOB_RECURSE SOURCES "src/*.cpp")
file(GLOB_RECURSE TESTS "src/*.test.cpp")
list(REMOVE_ITEM SOURCES ${TESTS})
-add_library(luci_env SHARED ${SOURCES})
+if (NOT LUCI_LIBRARY_TYPE)
+ set(LUCI_LIBRARY_TYPE "SHARED")
+endif(NOT LUCI_LIBRARY_TYPE)
+
+add_library(luci_env ${LUCI_LIBRARY_TYPE} ${SOURCES})
target_include_directories(luci_env PUBLIC include)
target_link_libraries(luci_env PRIVATE nncc_common)
install(TARGETS luci_env DESTINATION lib)
+install(DIRECTORY include/ DESTINATION include
+ FILES_MATCHING PATTERN "*.h")
if(NOT ENABLE_TEST)
return()