summaryrefslogtreecommitdiff
path: root/compiler/logo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/logo/CMakeLists.txt')
-rw-r--r--compiler/logo/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/compiler/logo/CMakeLists.txt b/compiler/logo/CMakeLists.txt
new file mode 100644
index 000000000..399cb7586
--- /dev/null
+++ b/compiler/logo/CMakeLists.txt
@@ -0,0 +1,23 @@
+file(GLOB_RECURSE SOURCES "src/*.cpp")
+file(GLOB_RECURSE TESTS "src/*.test.cpp")
+list(REMOVE_ITEM SOURCES ${TESTS})
+
+add_library(logo STATIC ${SOURCES})
+set_target_properties(logo PROPERTIES POSITION_INDEPENDENT_CODE ON)
+target_include_directories(logo PRIVATE src)
+target_include_directories(logo PUBLIC include)
+target_link_libraries(logo PUBLIC loco)
+target_link_libraries(logo PUBLIC logo_core)
+target_link_libraries(logo PRIVATE locomotiv)
+target_link_libraries(logo PRIVATE stdex)
+
+if(NOT ENABLE_TEST)
+ return()
+endif(NOT ENABLE_TEST)
+
+nnas_find_package(GTest REQUIRED)
+
+GTest_AddTest(logo_test ${TESTS})
+target_include_directories(logo_test PRIVATE src)
+target_link_libraries(logo_test logo)
+target_link_libraries(logo_test stdex)