summaryrefslogtreecommitdiff
path: root/compiler/gen-core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/gen-core/CMakeLists.txt')
-rw-r--r--compiler/gen-core/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/compiler/gen-core/CMakeLists.txt b/compiler/gen-core/CMakeLists.txt
new file mode 100644
index 000000000..3732f493b
--- /dev/null
+++ b/compiler/gen-core/CMakeLists.txt
@@ -0,0 +1,17 @@
+find_package(HDF5 COMPONENTS CXX QUIET)
+
+if(NOT HDF5_FOUND)
+ return()
+endif(NOT HDF5_FOUND)
+
+nnas_find_package(TensorFlow QUIET)
+
+file(GLOB_RECURSE SOURCES "src/*.cpp")
+
+add_library(gen_core STATIC ${SOURCES})
+set_target_properties(gen_core PROPERTIES POSITION_INDEPENDENT_CODE ON)
+target_include_directories(gen_core PUBLIC include)
+target_include_directories(gen_core PRIVATE ${HDF5_INCLUDE_DIRS})
+target_link_libraries(gen_core ${HDF5_CXX_LIBRARIES})
+target_link_libraries(gen_core tfinfo_v2)
+target_link_libraries(gen_core angkor)