summaryrefslogtreecommitdiff
path: root/compiler/fipe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/fipe/CMakeLists.txt')
-rw-r--r--compiler/fipe/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/compiler/fipe/CMakeLists.txt b/compiler/fipe/CMakeLists.txt
new file mode 100644
index 000000000..2cabf6279
--- /dev/null
+++ b/compiler/fipe/CMakeLists.txt
@@ -0,0 +1,11 @@
+add_library(fipe INTERFACE)
+target_include_directories(fipe INTERFACE include)
+
+if(NOT ENABLE_TEST)
+ return()
+endif(NOT ENABLE_TEST)
+
+nnas_find_package(GTest REQUIRED)
+
+GTest_AddTest(fipe_test fipe.test.cpp)
+target_link_libraries(fipe_test fipe)