summaryrefslogtreecommitdiff
path: root/compiler/encodump/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/encodump/CMakeLists.txt')
-rw-r--r--compiler/encodump/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/compiler/encodump/CMakeLists.txt b/compiler/encodump/CMakeLists.txt
new file mode 100644
index 000000000..58fe17a51
--- /dev/null
+++ b/compiler/encodump/CMakeLists.txt
@@ -0,0 +1,17 @@
+if(NOT TARGET enco_intf_frontend)
+ return()
+endif(NOT TARGET enco_intf_frontend)
+
+if(NOT TARGET enco_core)
+ return()
+endif(NOT TARGET enco_core)
+
+file(GLOB_RECURSE SOURCES "src/*.cpp")
+
+add_executable(encodump ${SOURCES})
+target_include_directories(encodump PRIVATE src)
+target_link_libraries(encodump enco_intf_frontend)
+target_link_libraries(encodump enco_core)
+target_link_libraries(encodump safemain)
+target_link_libraries(encodump stdex)
+target_link_libraries(encodump dl)