summaryrefslogtreecommitdiff
path: root/compiler/circle2circle-dredd-recipe-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/circle2circle-dredd-recipe-test/CMakeLists.txt')
-rw-r--r--compiler/circle2circle-dredd-recipe-test/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/compiler/circle2circle-dredd-recipe-test/CMakeLists.txt b/compiler/circle2circle-dredd-recipe-test/CMakeLists.txt
index 4bcaae347..9ccfd0008 100644
--- a/compiler/circle2circle-dredd-recipe-test/CMakeLists.txt
+++ b/compiler/circle2circle-dredd-recipe-test/CMakeLists.txt
@@ -1,3 +1,7 @@
+if(NOT ENABLE_TEST)
+ return()
+endif(NOT ENABLE_TEST)
+
nnas_include(TargetRequire)
unset(REQUIRED_TARGETS)
@@ -69,7 +73,7 @@ add_custom_command(
COMMAND ${CMAKE_COMMAND} -E remove -f ${TEST_CONFIG}
COMMAND ${CMAKE_COMMAND} -E echo 'CIRCLE_INSPECT_PATH=\"$<TARGET_FILE:circle-inspect>\"' >> ${TEST_CONFIG}
COMMAND ${CMAKE_COMMAND} -E echo 'CIRCLE_VERIFY_PATH=\"$<TARGET_FILE:circle-verify>\"' >> ${TEST_CONFIG}
- DEPENDS
+ DEPENDS
circle-inspect
circle-verify
COMMENT "Generate test configuration"