summaryrefslogtreecommitdiff
path: root/compiler/circle-verify/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/circle-verify/CMakeLists.txt')
-rw-r--r--compiler/circle-verify/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/compiler/circle-verify/CMakeLists.txt b/compiler/circle-verify/CMakeLists.txt
new file mode 100644
index 000000000..2e19951e1
--- /dev/null
+++ b/compiler/circle-verify/CMakeLists.txt
@@ -0,0 +1,12 @@
+if(NOT TARGET mio_circle)
+ return()
+endif(NOT TARGET mio_circle)
+
+file(GLOB_RECURSE SOURCES "src/*.cpp")
+
+add_executable(circle-verify ${SOURCES})
+target_include_directories(circle-verify PRIVATE src)
+target_link_libraries(circle-verify mio_circle)
+target_link_libraries(circle-verify safemain)
+target_link_libraries(circle-verify cwrap)
+target_link_libraries(circle-verify stdex)