summaryrefslogtreecommitdiff
path: root/compiler/circle-operator/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/circle-operator/CMakeLists.txt')
-rw-r--r--compiler/circle-operator/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/compiler/circle-operator/CMakeLists.txt b/compiler/circle-operator/CMakeLists.txt
new file mode 100644
index 000000000..33d9a96d0
--- /dev/null
+++ b/compiler/circle-operator/CMakeLists.txt
@@ -0,0 +1,17 @@
+if(NOT TARGET mio_circle06)
+ return()
+endif(NOT TARGET mio_circle06)
+
+set(DRIVER "driver/Driver.cpp")
+
+file(GLOB_RECURSE SOURCES "src/*.cpp")
+
+add_executable(circle-operator ${DRIVER} ${SOURCES})
+target_include_directories(circle-operator PRIVATE src)
+target_link_libraries(circle-operator arser)
+target_link_libraries(circle-operator foder)
+target_link_libraries(circle-operator mio_circle06)
+target_link_libraries(circle-operator mio_circle06_helper)
+target_link_libraries(circle-operator safemain)
+
+install(TARGETS circle-operator DESTINATION bin)