summaryrefslogtreecommitdiff
path: root/compiler/caffegen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/caffegen/CMakeLists.txt')
-rw-r--r--compiler/caffegen/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/compiler/caffegen/CMakeLists.txt b/compiler/caffegen/CMakeLists.txt
new file mode 100644
index 000000000..334174dcd
--- /dev/null
+++ b/compiler/caffegen/CMakeLists.txt
@@ -0,0 +1,14 @@
+nnas_find_package(Caffe QUIET)
+
+if(NOT Caffe_FOUND)
+ return()
+endif(NOT Caffe_FOUND)
+
+file(GLOB_RECURSE SOURCES "src/*.cpp")
+
+add_executable(caffegen ${SOURCES})
+target_link_libraries(caffegen stdex)
+target_link_libraries(caffegen cli)
+# NOTE "Caffe" package provides both caffe and caffeproto target
+# NOTE "caffeproto" is linked to "caffe"
+target_link_libraries(caffegen caffe)