summaryrefslogtreecommitdiff
path: root/compiler/bino/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/bino/CMakeLists.txt')
-rw-r--r--compiler/bino/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/compiler/bino/CMakeLists.txt b/compiler/bino/CMakeLists.txt
new file mode 100644
index 000000000..519eecdc8
--- /dev/null
+++ b/compiler/bino/CMakeLists.txt
@@ -0,0 +1,14 @@
+add_library(bino INTERFACE)
+target_include_directories(bino INTERFACE include)
+
+if(NOT ENABLE_TEST)
+ return()
+endif(NOT ENABLE_TEST)
+
+# Google Test is mandatory for internal testing
+nnas_find_package(GTest REQUIRED)
+
+file(GLOB_RECURSE TESTS "tests/*.cpp")
+
+GTest_AddTest(bino_test ${TESTS})
+target_link_libraries(bino_test bino)