summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 19 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fd9be5f30..34824ff71 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,16 +38,26 @@ link_directories(${CMAKE_INSTALL_PREFIX}/lib)
# Download configuration
option(DOWNLOAD_TENSORFLOW "Download Tensorflow source" ON)
+option(DOWNLOAD_ABSL "Download Absl source" ON)
option(DOWNLOAD_EIGEN "Download Eigen source" ON)
option(DOWNLOAD_FARMHASH "Download farmhash source" ON)
option(DOWNLOAD_GEMMLOWP "Download GEMM low precesion library source" ON)
option(DOWNLOAD_NEON2SSE "Download NEON2SSE library source" ON)
option(DOWNLOAD_FLATBUFFERS "Download FlatBuffers source" ON)
+option(DOWNLOAD_ARMCOMPUTE "Download ARM Compute source" ON)
+option(DOWNLOAD_NONIUS "Download nonius source" ON)
# GTest support
option(BUILD_GTEST "Download and build Google Test" ON)
nnfw_find_package(GTest QUIET)
+# NOTE Workaround to avoid build fail by tensorflow (or acl) package version mismatch on obs build
+if(OBS_BUILD)
+ add_definitions(-DOBS_BUILD)
+endif(OBS_BUILD)
+
+nnfw_include(ExtendCMakeFunction)
+
# TODO For now Android build is being enabled incrementally so not all subdirectories are added yet.
# However we are going to have the same subdirectories with other OS eventually.
if("${TARGET_OS}" STREQUAL "android")
@@ -60,21 +70,22 @@ if("${TARGET_OS}" STREQUAL "android")
add_subdirectory(libs)
add_subdirectory(externals)
- add_subdirectory(tools/nnapi_test)
- add_subdirectory(tools/tflite_benchmark)
+ add_subdirectory(tests/tools/nnapi_test)
+ add_subdirectory(tests/tools/tflite_benchmark)
+ add_subdirectory(tests/nnapi)
add_subdirectory(runtimes)
else("${TARGET_OS}" STREQUAL "android") # General case (non-android build)
- if (NOT OBS_BUILD)
+ if(NOT OBS_BUILD)
add_subdirectory(externals)
- endif()
- add_subdirectory(libs)
- add_subdirectory(tools)
- add_subdirectory(runtimes)
+ endif(NOT OBS_BUILD)
- add_subdirectory(benchmark)
add_subdirectory(contrib)
+ add_subdirectory(libs)
+ add_subdirectory(runtimes)
+ add_subdirectory(tests)
+ add_subdirectory(tools)
endif("${TARGET_OS}" STREQUAL "android")