summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0979a4a3f..3b558f42d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,10 +58,13 @@ option(DOWNLOAD_NONIUS "Download nonius source" ON)
option(BUILD_GTEST "Download and build Google Test" ON)
nnfw_find_package(GTest QUIET)
-# NOTE Workaround to avoid build fail by tensorflow (or acl) package version mismatch on obs build
-if(OBS_BUILD)
- add_definitions(-DOBS_BUILD)
-endif(OBS_BUILD)
+# NOTE For now NNFW supports two TFLITE versions - v1.12 for Unbuntu and v1.9 for Tizen.
+# So TFLITE version should mandatorily be specified to distinguish the version.
+if(NOT TFLITE_MAJOR_VER OR NOT TFLITE_MINOR_VER)
+ message(FATAL_ERROR "TFLITE_MAJOR_VER and TFLITE_MINOR_VER should be defined")
+endif(NOT TFLITE_MAJOR_VER OR NOT TFLITE_MINOR_VER)
+
+add_definitions(-DTFLITE_MAJOR_VER=${TFLITE_MAJOR_VER} -DTFLITE_MINOR_VER=${TFLITE_MINOR_VER})
nnfw_include(ExtendCMakeFunction)