summaryrefslogtreecommitdiff
path: root/tools/tflite_benchmark_model/CMakeLists.txt
diff options
context:
space:
mode:
author이상규/동작제어Lab(SR)/Principal Engineer/삼성전자 <sg5.lee@samsung.com>2018-11-26 14:56:12 +0900
committer오형석/동작제어Lab(SR)/Staff Engineer/삼성전자 <hseok82.oh@samsung.com>2018-11-26 14:56:12 +0900
commit9fe5ce4d9d386e50e529e52b09bb4951d887a7b1 (patch)
tree394716a4b8aa3eeb16a8863f1b6ba408377c1760 /tools/tflite_benchmark_model/CMakeLists.txt
parentaf76fbca19f76449164406f7ff2e69dc8e6a5c88 (diff)
downloadnnfw-9fe5ce4d9d386e50e529e52b09bb4951d887a7b1.tar.gz
nnfw-9fe5ce4d9d386e50e529e52b09bb4951d887a7b1.tar.bz2
nnfw-9fe5ce4d9d386e50e529e52b09bb4951d887a7b1.zip
tflite_benchmark_model is updated to v1.12.0. (#3660)
Most files are not changed from v1.12.0. My modification is to support multiple kernel expansion operators. You can find the changes from stats_calculator.cc and profile_summarizer.cc. Signed-off-by: Sanggyu Lee <sg5.lee@samsung.com>
Diffstat (limited to 'tools/tflite_benchmark_model/CMakeLists.txt')
-rw-r--r--tools/tflite_benchmark_model/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/tflite_benchmark_model/CMakeLists.txt b/tools/tflite_benchmark_model/CMakeLists.txt
index d52690460..dd54dc5b5 100644
--- a/tools/tflite_benchmark_model/CMakeLists.txt
+++ b/tools/tflite_benchmark_model/CMakeLists.txt
@@ -1,5 +1,12 @@
file(GLOB_RECURSE SOURCES "*.cc")
+nnfw_find_package(TensorFlowSource REQUIRED)
+set(TENSORFLOW_LITE_BASE "${TensorFlowSource_DIR}/tensorflow/contrib/lite")
+list(APPEND SOURCES "${TENSORFLOW_LITE_BASE}/tools/benchmark/benchmark_main.cc"
+ "${TENSORFLOW_LITE_BASE}/tools/benchmark/benchmark_model.cc"
+ "${TENSORFLOW_LITE_BASE}/tools/benchmark/benchmark_params.cc"
+ "${TENSORFLOW_LITE_BASE}/tools/benchmark/command_line_flags.cc")
+
add_executable(tflite_benchmark_model ${SOURCES})
target_compile_definitions(tflite_benchmark_model PUBLIC "TFLITE_PROFILING_ENABLED")
target_link_libraries(tflite_benchmark_model tensorflow-lite ${LIB_PTHREAD} dl nnfw_util nnfw_support_tflite)