summaryrefslogtreecommitdiff
path: root/compiler/loco/CMakeLists.txt
diff options
context:
space:
mode:
authorChunseok Lee <chunseok.lee@samsung.com>2020-10-29 13:12:50 +0900
committerChunseok Lee <chunseok.lee@samsung.com>2020-10-29 13:12:50 +0900
commitd6b371e095d737922187a518b8faba1ef6f3a2b1 (patch)
tree9d90c09c887b5111389dbedf924f59206411cd5a /compiler/loco/CMakeLists.txt
parentc55f8a6db48cda9d3a78048338b7f18c4cca62b8 (diff)
downloadnnfw-d6b371e095d737922187a518b8faba1ef6f3a2b1.tar.gz
nnfw-d6b371e095d737922187a518b8faba1ef6f3a2b1.tar.bz2
nnfw-d6b371e095d737922187a518b8faba1ef6f3a2b1.zip
Imported Upstream version 0.4upstream/0.4
Diffstat (limited to 'compiler/loco/CMakeLists.txt')
-rw-r--r--compiler/loco/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/compiler/loco/CMakeLists.txt b/compiler/loco/CMakeLists.txt
index f94052840..8d1a85770 100644
--- a/compiler/loco/CMakeLists.txt
+++ b/compiler/loco/CMakeLists.txt
@@ -13,16 +13,17 @@ target_link_libraries(loco PRIVATE stdex)
# Please refer to the top-level CMakeLists.txt for details
target_link_libraries(loco PRIVATE nncc_common)
target_link_libraries(loco PUBLIC nncc_coverage)
-# Q. HOW TO MAKE DEV PACKAGE(?)
-install(TARGETS loco DESTINATION lib)
if(NOT ENABLE_TEST)
return()
endif(NOT ENABLE_TEST)
# Google Test is mandatory for internal testing
-nnas_find_package(GTest REQUIRED)
+nncc_find_package(GTest REQUIRED)
-GTest_AddTest(loco_test ${TESTS})
+add_executable(loco_test ${TESTS})
+target_link_libraries(loco_test gtest_main)
target_link_libraries(loco_test stdex)
target_link_libraries(loco_test loco)
+
+add_test(loco_test loco_test)