summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
author박종현/On-Device Lab(SR)/Staff Engineer/삼성전자 <jh1302.park@samsung.com>2019-03-11 14:58:21 +0900
committer오형석/On-Device Lab(SR)/Staff Engineer/삼성전자 <hseok82.oh@samsung.com>2019-03-11 14:58:21 +0900
commitd9cfd3c2f879ec28df0a6b81a1d5c70432afb9f1 (patch)
tree6b1efaa5c70b86ef87c570f8ae8c6782b54039ec /CMakeLists.txt
parent6f8a32abb0735e073e7705a109317d731701673d (diff)
downloadnnfw-d9cfd3c2f879ec28df0a6b81a1d5c70432afb9f1.tar.gz
nnfw-d9cfd3c2f879ec28df0a6b81a1d5c70432afb9f1.tar.bz2
nnfw-d9cfd3c2f879ec28df0a6b81a1d5c70432afb9f1.zip
Introduce BUILD_TENSORFLOW_LITE option (#4658)
This commit introduces BUILD_TENSORFLOW_LITE option and removes one occurences of OBS_BUILD in CMakeLists.txt via using this flag instead. Signed-off-by: Jonghyun Park <jh1302.park@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 02b52578c..dd83f6998 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,6 +53,7 @@ option(DOWNLOAD_FARMHASH "Download farmhash source" ON)
option(DOWNLOAD_GEMMLOWP "Download GEMM low precesion library source" ON)
option(DOWNLOAD_NEON2SSE "Download NEON2SSE library source" ON)
option(DOWNLOAD_FLATBUFFERS "Download FlatBuffers source" ON)
+option(BUILD_TENSORFLOW_LITE "Build TensorFlow Lite from the downloaded source" ON)
option(DOWNLOAD_ARMCOMPUTE "Download ARM Compute source" ON)
option(BUILD_ARMCOMPUTE "Build ARM Compute from the downloaded source" ON)
option(DOWNLOAD_NONIUS "Download nonius source" ON)
@@ -91,10 +92,7 @@ if("${TARGET_OS}" STREQUAL "android")
else("${TARGET_OS}" STREQUAL "android") # General case (non-android build)
- if(NOT OBS_BUILD)
- add_subdirectory(externals)
- endif(NOT OBS_BUILD)
-
+ add_subdirectory(externals)
add_subdirectory(contrib)
add_subdirectory(libs)
add_subdirectory(runtimes)