summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
author오형석/On-Device Lab(SR)/Staff Engineer/삼성전자 <hseok82.oh@samsung.com>2019-03-20 16:36:22 +0900
committerGitHub Enterprise <noreply-CODE@samsung.com>2019-03-20 16:36:22 +0900
commitd51fa839cb653211722d6fd2ff9c369fd2c5a862 (patch)
tree49d31aceb13a016f685442291afe2024098b9b1a /CMakeLists.txt
parenta4c0bcf1501c3168666a94cdf61d9fd1618c7928 (diff)
downloadnnfw-d51fa839cb653211722d6fd2ff9c369fd2c5a862.tar.gz
nnfw-d51fa839cb653211722d6fd2ff9c369fd2c5a862.tar.bz2
nnfw-d51fa839cb653211722d6fd2ff9c369fd2c5a862.zip
Fix cmake regular expression bug (#4790)
Use variable setting instead of regular expression because option setting by cmake configure is not working It is temporary solution until changing option setting for each architecture Signed-off-by: Hyeongseok Oh <hseok82.oh@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0d37eb308..18b7ae9be 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,9 +60,9 @@ option(BUILD_TENSORFLOW_LITE "Build TensorFlow Lite from the downloaded source"
option(DOWNLOAD_ARMCOMPUTE "Download ARM Compute source" ON)
CMAKE_DEPENDENT_OPTION(BUILD_ARMCOMPUTE "Build ARM Compute from the downloaded source"
# Enable ARMCompute build if the target architecture is aarch
- OFF "NOT ${TARGET_ARCH_BASE} MATCHES arm*;NOT ${TARGET_ARCH_BASE} MATCHES aarch*"
+ ON "TARGET_IS_ARMARCH"
# Disable ARMCompute build otherwise
- ON)
+ OFF)
option(DOWNLOAD_NONIUS "Download nonius source" ON)
option(DOWNLOAD_BOOST "Download boost source" OFF)
option(BUILD_BOOST "Build boost source" OFF)