summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
author오형석/동작제어Lab(SR)/Staff Engineer/삼성전자 <hseok82.oh@samsung.com>2018-09-11 16:39:27 +0900
committer박세희/동작제어Lab(SR)/Principal Engineer/삼성전자 <saehie.park@samsung.com>2018-09-11 16:39:27 +0900
commit7db9d9592e1aea2cc17f4a16a7fab0cade99ef57 (patch)
treee917f3c34f319fd07e5707c69b6172415b1b2181 /CMakeLists.txt
parent31d2a12cb20f4880f4ea81b33ad12d3287963555 (diff)
downloadnnfw-7db9d9592e1aea2cc17f4a16a7fab0cade99ef57.tar.gz
nnfw-7db9d9592e1aea2cc17f4a16a7fab0cade99ef57.tar.bz2
nnfw-7db9d9592e1aea2cc17f4a16a7fab0cade99ef57.zip
Change gtest download cmake script (#2659)
Change gtest download cmake script simliar with nncc Prepare supporting public server and mirror server download Signed-off-by: Hyeongseok Oh <hseok82.oh@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 35114c5c0..1aedc66eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,7 +33,8 @@ include("cmake/CfgOptionFlags.cmake")
link_directories(${CMAKE_INSTALL_PREFIX}/lib)
# GTest support
-include("cmake/support/gtest.cmake")
+option(BUILD_GTEST "Download and build Google Test" ON)
+nnfw_find_package(GTest QUIET)
# TODO For now Android build is being enabled incrementally so not all subdirectories are added yet.
# However we are going to have the same subdirectories with other OS eventually.