summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
author박종현/On-Device Lab(SR)/Staff Engineer/삼성전자 <jh1302.park@samsung.com>2019-03-08 16:01:58 +0900
committer오형석/On-Device Lab(SR)/Staff Engineer/삼성전자 <hseok82.oh@samsung.com>2019-03-08 16:01:58 +0900
commit6c9ea2451f23f6ebb2d63a2ba75f7a7319c53cc4 (patch)
tree0692f16462f674a889613089826e117b32975616 /CMakeLists.txt
parenta92b7fb7d39f5950ed9fa13c21f9394665ef94f1 (diff)
downloadnnfw-6c9ea2451f23f6ebb2d63a2ba75f7a7319c53cc4.tar.gz
nnfw-6c9ea2451f23f6ebb2d63a2ba75f7a7319c53cc4.tar.bz2
nnfw-6c9ea2451f23f6ebb2d63a2ba75f7a7319c53cc4.zip
Introduce nnapi-header CMake target (#4631)
This commit introduces nnapi-header target in CMake, and removes all the occurences of NNFW_INCLUDE_DIR via linking this target instead. Signed-off-by: Jonghyun Park <jh1302.park@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f0b9d0329..f9a9f6514 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,6 +61,9 @@ nnfw_find_package(GTest QUIET)
nnfw_include(ExtendCMakeFunction)
+add_library(nnapi-header INTERFACE)
+target_include_directories(nnapi-header INTERFACE include)
+
# TODO For now Android build is being enabled incrementally so not all subdirectories are added yet.
# However we are going to have the same subdirectories with other OS eventually.
if("${TARGET_OS}" STREQUAL "android")