summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
author오형석/동작제어Lab(SR)/Staff Engineer/삼성전자 <hseok82.oh@samsung.com>2018-11-08 16:12:55 +0900
committer이춘석/동작제어Lab(SR)/Staff Engineer/삼성전자 <chunseok.lee@samsung.com>2018-11-08 16:12:55 +0900
commit19bb8e8e56b2775f5e77d0b562d0b08322635c74 (patch)
treea2c86bd2389f28ca782c504f5cdf9699f74d7608 /CMakeLists.txt
parentd01c9dc2320bdc1c218843e38e3e53f72b64142c (diff)
downloadnnfw-19bb8e8e56b2775f5e77d0b562d0b08322635c74.tar.gz
nnfw-19bb8e8e56b2775f5e77d0b562d0b08322635c74.tar.bz2
nnfw-19bb8e8e56b2775f5e77d0b562d0b08322635c74.zip
Update tensorflow to v1.12 (#3486)
* Update external package - Update external package version - Update cmake to build tflite - Add gitignore for new external code * Update library to support tflite - Update nnapi delegate - Update NeuralNetworksShim.h for new API - Fix cmake for new files in updated tensorflow - Workaround: Introduce OBS_BUILD flag to avoid gbs build fail * Update neurun CPU kernel - Update neurun CPU kernel to call updated tflite interpreter kernel - Add build option -fPIC for updated tflite kernel Signed-off-by: Hyeongseok Oh <hseok82.oh@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6238ce073..85a81dd94 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,6 +38,7 @@ link_directories(${CMAKE_INSTALL_PREFIX}/lib)
# Download configuration
option(DOWNLOAD_TENSORFLOW "Download Tensorflow source" ON)
+option(DOWNLOAD_ABSL "Download Absl source" ON)
option(DOWNLOAD_EIGEN "Download Eigen source" ON)
option(DOWNLOAD_FARMHASH "Download farmhash source" ON)
option(DOWNLOAD_GEMMLOWP "Download GEMM low precesion library source" ON)
@@ -49,6 +50,11 @@ option(DOWNLOAD_ARMCOMPUTE "Download ARM Compute source" ON)
option(BUILD_GTEST "Download and build Google Test" ON)
nnfw_find_package(GTest QUIET)
+# NOTE Workaround to avoid build fail by tensorflow (or acl) package version mismatch on obs build
+if(OBS_BUILD)
+ add_definitions(-DOBS_BUILD)
+endif(OBS_BUILD)
+
# TODO For now Android build is being enabled incrementally so not all subdirectories are added yet.
# However we are going to have the same subdirectories with other OS eventually.
if("${TARGET_OS}" STREQUAL "android")