summaryrefslogtreecommitdiff
path: root/modules/webrtc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'modules/webrtc/CMakeLists.txt')
-rw-r--r--modules/webrtc/CMakeLists.txt26
1 files changed, 13 insertions, 13 deletions
diff --git a/modules/webrtc/CMakeLists.txt b/modules/webrtc/CMakeLists.txt
index 9029d59..04fe831 100644
--- a/modules/webrtc/CMakeLists.txt
+++ b/modules/webrtc/CMakeLists.txt
@@ -1,17 +1,17 @@
-SET(AITT_WEBRTC aitt-stream-webrtc)
+set(AITT_WEBRTC aitt-stream-webrtc)
-INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
-PKG_CHECK_MODULES(AITT_WEBRTC_NEEDS REQUIRED
+pkg_check_modules(AITT_WEBRTC_NEEDS REQUIRED
capi-media-camera
capi-media-webrtc
gstreamer-video-1.0
json-glib-1.0
)
-INCLUDE_DIRECTORIES(${AITT_WEBRTC_NEEDS_INCLUDE_DIRS})
-LINK_DIRECTORIES(${AITT_WEBRTC_NEEDS_LIBRARY_DIRS})
+include_directories(${AITT_WEBRTC_NEEDS_INCLUDE_DIRS})
+link_directories(${AITT_WEBRTC_NEEDS_LIBRARY_DIRS})
-ADD_LIBRARY(WEBRTC_OBJ OBJECT
+add_library(WEBRTC_OBJ OBJECT
StreamManager.cc
SrcStreamManager.cc
SinkStreamManager.cc
@@ -20,12 +20,12 @@ ADD_LIBRARY(WEBRTC_OBJ OBJECT
WebRtcStream.cc
RequestServer.cc
)
-ADD_LIBRARY(${AITT_WEBRTC} SHARED $<TARGET_OBJECTS:WEBRTC_OBJ> Module.cc ../stream_entry.cc )
-TARGET_LINK_LIBRARIES(${AITT_WEBRTC} ${AITT_WEBRTC_NEEDS_LIBRARIES} ${AITT_COMMON})
-TARGET_COMPILE_OPTIONS(${AITT_WEBRTC} PUBLIC ${AITT_WEBRTC_NEEDS_CFLAGS_OTHER})
+add_library(${AITT_WEBRTC} SHARED $<TARGET_OBJECTS:WEBRTC_OBJ> Module.cc ../stream_entry.cc )
+target_link_libraries(${AITT_WEBRTC} ${AITT_WEBRTC_NEEDS_LIBRARIES} ${AITT_COMMON})
+target_compile_options(${AITT_WEBRTC} PUBLIC ${AITT_WEBRTC_NEEDS_CFLAGS_OTHER})
-INSTALL(TARGETS ${AITT_WEBRTC} DESTINATION ${CMAKE_INSTALL_LIBDIR})
+install(TARGETS ${AITT_WEBRTC} DESTINATION ${CMAKE_INSTALL_LIBDIR})
-IF(BUILD_TESTING)
- ADD_SUBDIRECTORY(tests)
-ENDIF(BUILD_TESTING)
+if(BUILD_TESTING)
+ add_subdirectory(tests)
+endif(BUILD_TESTING)