summaryrefslogtreecommitdiff
path: root/email-core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'email-core/CMakeLists.txt')
-rwxr-xr-xemail-core/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/email-core/CMakeLists.txt b/email-core/CMakeLists.txt
index 6a111cc..f4bd068 100755
--- a/email-core/CMakeLists.txt
+++ b/email-core/CMakeLists.txt
@@ -71,7 +71,7 @@ INCLUDE_DIRECTORIES(
INCLUDE(FindPkgConfig)
-pkg_check_modules(storage_pkgs REQUIRED glib-2.0 dlog openssl vconf dbus-1 contacts-service2 libtzplatform-config)
+pkg_check_modules(storage_pkgs REQUIRED glib-2.0 dlog openssl1.1 vconf dbus-1 contacts-service2 libtzplatform-config)
set(EXTRA_CFLAGS "")
FOREACH(flag ${storage_pkgs_CFLAGS})
@@ -110,7 +110,7 @@ INCLUDE_DIRECTORIES(
)
INCLUDE(FindPkgConfig)
-pkg_check_modules(network_pkgs REQUIRED glib-2.0 uw-imap-toolkit dbus-1 vconf dlog openssl)
+pkg_check_modules(network_pkgs REQUIRED glib-2.0 uw-imap-toolkit dbus-1 vconf dlog openssl1.1)
FOREACH(flag ${network_pkgs_CFLAGS})
SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
@@ -234,8 +234,8 @@ INCLUDE_DIRECTORIES(
INCLUDE(FindPkgConfig)
SET(PKG_MODULES glib-2.0 dlog dbus-1 gthread-2.0 key-manager tpkp-curl
- uw-imap-toolkit vconf vconf-internal-keys contacts-service2
- openssl accounts-svc alarm-service notification libcurl libxml-2.0
+ uw-imap-toolkit vconf vconf-internal-keys contacts-service2
+ openssl1.1 accounts-svc alarm-service notification libcurl libxml-2.0
cert-svc-vcore badge capi-appfw-application icu-i18n gmime-2.6 storage dpm cryptsvc)
pkg_check_modules(core_pkgs REQUIRED ${PKG_MODULES})