summaryrefslogtreecommitdiff
path: root/packaging/liblocation-appman.spec
diff options
context:
space:
mode:
authorJinkun Jang <jinkun.jang@samsung.com>2013-03-13 01:48:41 +0900
committerJinkun Jang <jinkun.jang@samsung.com>2013-03-13 01:48:41 +0900
commitef99ea8e643867d3964802a98e761c609bd1c571 (patch)
tree22004252f53ea163707b6276be9d0b730d4bc625 /packaging/liblocation-appman.spec
parent0fa210fc66f335511720a78103ad1f4497a06ad6 (diff)
downloadliblocation-appman-ef99ea8e643867d3964802a98e761c609bd1c571.tar.gz
liblocation-appman-ef99ea8e643867d3964802a98e761c609bd1c571.tar.bz2
liblocation-appman-ef99ea8e643867d3964802a98e761c609bd1c571.zip
Tizen 2.1 base
Diffstat (limited to 'packaging/liblocation-appman.spec')
-rw-r--r--packaging/liblocation-appman.spec70
1 files changed, 70 insertions, 0 deletions
diff --git a/packaging/liblocation-appman.spec b/packaging/liblocation-appman.spec
new file mode 100644
index 0000000..033e28b
--- /dev/null
+++ b/packaging/liblocation-appman.spec
@@ -0,0 +1,70 @@
+%define _optdir /opt
+Name: liblocation-appman
+Summary: Location DB controler
+Version: 0.1.6
+Release: 1
+Group: System/Libraries
+License: TBD
+Source0: %{name}-%{version}.tar.gz
+
+Requires(post): sqlite
+BuildRequires: cmake
+BuildRequires: pkgconfig(glib-2.0)
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(sqlite3)
+BuildRequires: pkgconfig(libxml-2.0)
+BuildRequires: pkgconfig(capi-appfw-app-manager)
+BuildRequires: libgcrypt-devel
+
+%description
+Description: Location DB controller library
+
+
+%package devel
+Summary: Location DB controller (Development files)
+Group: System/Libraries
+Requires: %{name} = %{version}-%{release}
+
+%description devel
+Description : Location DB controller Development Package
+
+
+%prep
+%setup -q -n %{name}-%{version}
+
+
+%build
+cmake . -DCMAKE_INSTALL_PREFIX=/usr
+
+# Call make instruction with smp support
+make %{?jobs:-j%jobs}
+
+%post
+/sbin/ldconfig
+
+chown 0:5000 /opt/dbspace/.location-appman.db*
+chmod 664 /opt/dbspace/.location-appman.db*
+if [ -f /usr/lib/rpm-plugins/msm.so ]
+then
+chsmack -a 'location_fw::db' /opt/dbspace/.location-appman.db*
+fi
+
+%postun -p /sbin/ldconfig
+
+%install
+rm -rf %{buildroot}
+%make_install
+
+
+%clean
+rm -rf %{buildroot}
+
+%files
+%manifest liblocation-appman.manifest
+%defattr(-,root,root,-)
+%{_libdir}/liblocation-appman.so*
+%{_optdir}/dbspace/.location-appman.db*
+
+%files devel
+%{_includedir}/location-appman/*.h
+%{_libdir}/pkgconfig/*.pc