summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJunfeng Dong <junfeng.dong@intel.com>2013-03-25 18:57:18 +0800
committerlifang <fangx.li@intel.com>2013-03-29 05:23:15 +0800
commitbf5f6ec227c7f0030985a6bc4a1fc34226c986ea (patch)
tree897833482b0e5b93b7d6847ca838428df9cdbd84 /CMakeLists.txt
parentef99ea8e643867d3964802a98e761c609bd1c571 (diff)
downloadliblocation-appman-bf5f6ec227c7f0030985a6bc4a1fc34226c986ea.tar.gz
liblocation-appman-bf5f6ec227c7f0030985a6bc4a1fc34226c986ea.tar.bz2
liblocation-appman-bf5f6ec227c7f0030985a6bc4a1fc34226c986ea.zip
- Fix hardcoding path. - Use %cmake to set default paths. Change-Id: Id4d3c9b745f2cb323f540177a7c6bb687d4c1ebb
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 30edd2a..51333b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,7 @@ ADD_DEFINITIONS("-DPREFIX=\"${CMAKE_INSTALL_PREFIX}\"")
ADD_DEFINITIONS("-DTIZEN_DEBUG")
ADD_DEFINITIONS("-DLOCATION_APPMAN_DBDIR=\"${DBDIR}\"")
-SET(CMAKE_EXE_LINKER_FLAGS "-Wl,--as-needed -Wl,--rpath=/usr/lib")
+SET(CMAKE_EXE_LINKER_FLAGS "-Wl,--as-needed -Wl,--rpath=${LIB_INSTALL_DIR}")
aux_source_directory(src SOURCES)
ADD_LIBRARY(${fw_name} SHARED ${SOURCES})
@@ -41,9 +41,9 @@ SET_TARGET_PROPERTIES(${fw_name}
TARGET_LINK_LIBRARIES(${fw_name} ${${fw_name}_LDFLAGS} "-lgcrypt")
-INSTALL(TARGETS ${fw_name} DESTINATION lib)
+INSTALL(TARGETS ${fw_name} DESTINATION ${LIB_INSTALL_DIR})
INSTALL(
- DIRECTORY ${INC_DIR}/ DESTINATION include/location-appman
+ DIRECTORY ${INC_DIR}/ DESTINATION ${INCLUDE_INSTALL_DIR}/location-appman
FILES_MATCHING
PATTERN "${INC_DIR}/location-appman.h"
PATTERN "${INC_DIR}/location-appman-crypt.h"
@@ -67,7 +67,7 @@ CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/${fw_name}.pc
@ONLY
)
-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${fw_name}.pc DESTINATION lib/pkgconfig)
+INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${fw_name}.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
#create db
#INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/location-appman.sql DESTINATION ${ETCDIR})