summaryrefslogtreecommitdiff
path: root/packaging/geofence-server.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/geofence-server.spec')
-rw-r--r--packaging/geofence-server.spec35
1 files changed, 2 insertions, 33 deletions
diff --git a/packaging/geofence-server.spec b/packaging/geofence-server.spec
index 90d7172..8321894 100644
--- a/packaging/geofence-server.spec
+++ b/packaging/geofence-server.spec
@@ -1,6 +1,6 @@
Name: geofence-server
Summary: Geofence Server for Tizen
-Version: 0.4.1
+Version: 0.4.2
Release: 1
Group: Location/Service
License: Apache-2.0
@@ -26,14 +26,12 @@ BuildRequires: pkgconfig(alarm-service)
BuildRequires: pkgconfig(deviced)
BuildRequires: pkgconfig(vconf)
BuildRequires: pkgconfig(vconf-internal-keys)
+BuildRequires: pkgconfig(capi-system-info)
BuildRequires: pkgconfig(capi-appfw-app-manager)
BuildRequires: pkgconfig(capi-location-manager)
BuildRequires: pkgconfig(capi-network-wifi)
BuildRequires: pkgconfig(capi-network-bluetooth)
BuildRequires: pkgconfig(libcore-context-manager)
-#BuildRequires: pkgconfig(tapi)
-#BuildRequires: pkgconfig(capi-telephony-network-info)
-#BuildRequires: pkgconfig(capi-context-manager)
BuildRequires: pkgconfig(capi-geofence-manager)
BuildRequires: pkgconfig(libtzplatform-config)
BuildRequires: capi-geofence-manager-plugin-devel
@@ -62,42 +60,15 @@ make %{?jobs:-j%jobs}
rm -rf %{buildroot}
%make_install
-#[Workaround] create service file for systemd
mkdir -p %{buildroot}%{_unitdir_user}/default.target.wants
install -m 644 %{SOURCE1} %{buildroot}%{_unitdir_user}/geofence-server.service
ln -s ../geofence-server.service %{buildroot}%{_unitdir_user}/default.target.wants/geofence-server.service
-%if 0
-if [ ! -e "$GEOFENCE_SERVER_DB_PATH" ]
-then
-
-# create db
-mkdir -p %{buildroot}/opt/dbspace
-sqlite3 %{buildroot}/opt/dbspace/.geofence-server.db 'PRAGMA journal_mode = PERSIST;
- CREATE TABLE Places ( place_id INTEGER PRIMARY KEY AUTOINCREMENT, access_type INTEGER, place_name TEXT NOT NULL, app_id TEXT NOT NULL);
- CREATE TABLE GeoFence ( fence_id INTEGER PRIMARY KEY AUTOINCREMENT, place_id INTEGER, enable INTEGER, app_id TEXT NOT NULL, geofence_type INTEGER, access_type INTEGER, running_status INTEGER, FOREIGN KEY(place_id) REFERENCES Places(place_id) ON DELETE CASCADE);
- CREATE TABLE FenceGeocoordinate ( fence_id INTEGER , latitude TEXT NOT NULL, longitude TEXT NOT NULL, radius TEXT NOT NULL, address TEXT, FOREIGN KEY(fence_id) REFERENCES GeoFence(fence_id) ON DELETE CASCADE);
- CREATE TABLE FenceGeopointWifi ( fence_id INTEGER, bssid TEXT, ssid TEXT, FOREIGN KEY(fence_id) REFERENCES GeoFence(fence_id) ON DELETE CASCADE);
- CREATE TABLE FenceBssid ( fence_id INTEGER, bssid TEXT, ssid TEXT, FOREIGN KEY(fence_id) REFERENCES Geofence(fence_id) ON DELETE CASCADE);'
-fi
-%endif
-
%clean
rm -rf %{buildroot}
%post
-%if 0
-GEOFENCE_SERVER_DB_PATH="/opt/dbspace/.geofence-server.db"
-
-# geofence-server db file
-chown system:system /opt/dbspace/.geofence-server.db
-chown system:system /opt/dbspace/.geofence-server.db-journal
-# Change geofence-server db file permissions
-chmod 660 /opt/dbspace/.geofence-server.db
-chmod 660 /opt/dbspace/.geofence-server.db-journal
-%endif
-
%postun -p /sbin/ldconfig
%files
@@ -106,10 +77,8 @@ chmod 660 /opt/dbspace/.geofence-server.db-journal
/usr/bin/geofence-server
/usr/share/dbus-1/services/org.tizen.lbs.Providers.GeofenceServer.service
-#/opt/dbspace/.*.db*
%config %{_sysconfdir}/dbus-1/session.d/geofence-server.conf
-#[Workaround] create service file for systemd
%{_unitdir_user}/geofence-server.service
%{_unitdir_user}/default.target.wants/geofence-server.service