summaryrefslogtreecommitdiff
path: root/geofence/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'geofence/CMakeLists.txt')
-rw-r--r--geofence/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/geofence/CMakeLists.txt b/geofence/CMakeLists.txt
new file mode 100644
index 0000000..b450254
--- /dev/null
+++ b/geofence/CMakeLists.txt
@@ -0,0 +1,16 @@
+CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
+PROJECT(geofence-dbus-client C)
+
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/include)
+
+### Build ###
+SET(SRCS
+ src/geofence_client.c
+)
+
+ADD_LIBRARY(geofence-dbus-client SHARED ${SRCS})
+TARGET_LINK_LIBRARIES(geofence-dbus-client ${pkgs_LDFLAGS})
+SET_TARGET_PROPERTIES(geofence-dbus-client PROPERTIES VERSION 0.1.0 SOVERSION 0 OUTPUT_NAME geofence-dbus-client)
+
+INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/include/geofence_client.h DESTINATION include/geofence-dbus)
+INSTALL(TARGETS geofence-dbus-client DESTINATION ${LIBDIR} COMPONENT Runtime)