summaryrefslogtreecommitdiff
path: root/packaging/iotcon.spec
diff options
context:
space:
mode:
authorYoungjae Shin <yj99.shin@samsung.com>2016-03-15 11:45:03 +0900
committerYoungjae Shin <yj99.shin@samsung.com>2016-03-15 11:45:03 +0900
commit91732885654ab82ab5c226fa8d6c3c21d4d9c72e (patch)
tree793b9ab425970fa6101e8ef170467cb6df04583e /packaging/iotcon.spec
parent4a3a59494d5fa9ae5052b6b587c18e4befaa4d92 (diff)
downloadiotcon-91732885654ab82ab5c226fa8d6c3c21d4d9c72e.tar.gz
iotcon-91732885654ab82ab5c226fa8d6c3c21d4d9c72e.tar.bz2
iotcon-91732885654ab82ab5c226fa8d6c3c21d4d9c72e.zip
Change-Id: If26c4357a26cb91dca2f0ffd67743cffa013da16
Diffstat (limited to 'packaging/iotcon.spec')
-rw-r--r--packaging/iotcon.spec14
1 files changed, 12 insertions, 2 deletions
diff --git a/packaging/iotcon.spec b/packaging/iotcon.spec
index 337524d..b13b3c7 100644
--- a/packaging/iotcon.spec
+++ b/packaging/iotcon.spec
@@ -81,10 +81,20 @@ TZ_VER_3=0
TZ_VER_3=1
%endif
-export LDFLAGS+="-Wl,--as-needed"
+# for aarch64, x86_64
+%define BUILD_ARCH %{_arch}
+
+%ifarch armv7l armv7hl armv7nhl armv7tnhl armv7thl
+%define BUILD_ARCH "arm"
+%endif
+
+%ifarch %{ix86}
+%define BUILD_ARCH "x86"
+%endif
+
MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
%cmake . -DMAJORVER=${MAJORVER} -DFULLVER=%{version} -DBIN_INSTALL_DIR:PATH=%{_bindir} \
- -DTZ_VER_3=${TZ_VER_3} -DDBUS_INTERFACE=%{_dbus_interface}
+ -DTZ_VER_3=${TZ_VER_3} -DDBUS_INTERFACE=%{_dbus_interface} -DARCH=%{BUILD_ARCH}
%install