summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKibum Kim <kb0929.kim@samsung.com>2012-02-27 21:16:25 +0900
committerKibum Kim <kb0929.kim@samsung.com>2012-02-27 21:16:25 +0900
commitfe1d7b35e68d1e1743757e28c6d380baea8e35aa (patch)
tree57d038e12fd32a1a1cfcf0616123456d185d9667 /debian
downloadopengl-es-fe1d7b35e68d1e1743757e28c6d380baea8e35aa.tar.gz
opengl-es-fe1d7b35e68d1e1743757e28c6d380baea8e35aa.tar.bz2
opengl-es-fe1d7b35e68d1e1743757e28c6d380baea8e35aa.zip
tizen beta release
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/compat1
-rw-r--r--debian/control28
-rw-r--r--debian/dirs0
-rw-r--r--debian/docs0
-rw-r--r--debian/opengl-es-dev.install2
-rw-r--r--debian/opengl-es.install0
-rwxr-xr-xdebian/rules116
8 files changed, 154 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..fd2350a
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,7 @@
+opengl-es (0.1.1-4) unstable; urgency=low
+
+ * Initialize version
+ * Git: slp/pkgs/o/opengl-es
+ * Tag: opengl-es_0.1.1-4
+
+ -- Minsu Han <minsu81.han@samsung.com> Tue, 06 Dec 2011 19:25:29 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..f292664
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,28 @@
+Source: opengl-es
+Section: libs
+Priority: extra
+Maintainer: Minsu Han <minsu81.han@samsung.com>
+Build-Depends: debhelper (>= 5)
+Standards-Version: 3.7.2
+
+Package: opengl-es
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends},
+ opengl-es-drv [ armel ],
+ simulator-opengl [ i386 ]
+Description: metapackage for the OpenGL ES library
+ This is a meta package that will point to the latest OpenGL ES driver.
+ .
+ It does not provide any drivers itself.
+
+Package: opengl-es-dev
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends},
+ opengl-es,
+ opengl-es-drv-dev [ armel ],
+ simulator-opengl-dev [ i386 ]
+Description: metapackage for development files of the OpenGL ES library
+ This is a meta package that will point to the latest development libraries,
+ header files needed by programs that want to compile with OpenGL ES.
+ .
+ It does not provide any development files itself.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/debian/dirs
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/debian/docs
diff --git a/debian/opengl-es-dev.install b/debian/opengl-es-dev.install
new file mode 100644
index 0000000..b448fc3
--- /dev/null
+++ b/debian/opengl-es-dev.install
@@ -0,0 +1,2 @@
+usr/lib/pkgconfig/opengl-es-11.pc
+usr/lib/pkgconfig/opengl-es-20.pc
diff --git a/debian/opengl-es.install b/debian/opengl-es.install
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/debian/opengl-es.install
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..93aa459
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,116 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+PREFIX ?= /usr
+DESTDIR=$(CURDIR)/debian/tmp$(PREFIX)
+VERSION=0.1
+REQUIRES_PKG_PATH=
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+ifneq (,$(findstring arm, $(DEB_BUILD_ARCH)))
+ REQUIRES_PKG_PATH=pkgconfig_arm
+else
+ifneq (,$(findstring 86, $(DEB_BUILD_ARCH)))
+ REQUIRES_PKG_PATH=pkgconfig_i686
+endif
+endif
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ #$(MAKE)
+ #docbook-to-man debian/opengl-es.sgml > opengl-es.1
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ #-$(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/opengl-es.
+ #$(MAKE) DESTDIR=$(CURDIR)/debian/opengl-es install
+
+ @echo
+ @echo " REQUIRES_PKG_PATH = ${REQUIRES_PKG_PATH}"
+ @echo
+
+ mkdir -p $(DESTDIR)/lib/pkgconfig
+ cp -a ./${REQUIRES_PKG_PATH}/*.pc ${DESTDIR}/lib/pkgconfig/
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+# dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure