summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules85
1 files changed, 0 insertions, 85 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index f41458e..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-INSTALL_DIR = $(CURDIR)/debian/tmp
-CONFIG_NAME = 99-slp.conf
-
-configure: configure-stamp
-
-configure-stamp:
- touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- # Add here commands to clean up after the build process.
- -rm -rf $(INSTALL_DIR) clean
- -rm -rf $(CURDIR)/debian/default-fonts-fc-sdk
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/default-fonts-fc-slp.
- mkdir -p $(INSTALL_DIR)/usr/etc/fonts/conf.d/
- mkdir -p $(INSTALL_DIR)/usr/etc/fonts/conf.avail/ && cp -a $(CURDIR)/sdk_fonts_fc/* $(INSTALL_DIR)/usr/etc/fonts/conf.avail/
- cd $(INSTALL_DIR)/usr/etc/fonts/conf.d/
- ln -s ../conf.avail/$(CONFIG_NAME) $(INSTALL_DIR)/usr/etc/fonts/conf.d/$(CONFIG_NAME)
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installexamples
- dh_install --sourcedir=debian/tmp
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_python
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
-# dh_perl
-# dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure