summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKibum Kim <kb0929.kim@samsung.com>2012-02-27 21:15:51 +0900
committerKibum Kim <kb0929.kim@samsung.com>2012-02-27 21:15:51 +0900
commit09d307234071df1a9419de81d4b9b4193ea461fd (patch)
treee639e9d247ab7d7e05c3d2f3da196f75d01048c9 /debian
downloaddefault-fonts-fc-sdk-09d307234071df1a9419de81d4b9b4193ea461fd.tar.gz
default-fonts-fc-sdk-09d307234071df1a9419de81d4b9b4193ea461fd.tar.bz2
default-fonts-fc-sdk-09d307234071df1a9419de81d4b9b4193ea461fd.zip
tizen beta release
Diffstat (limited to 'debian')
-rw-r--r--debian/README.Debian6
-rw-r--r--debian/changelog7
-rw-r--r--debian/compat1
-rw-r--r--debian/control14
-rw-r--r--debian/default-fonts-fc-sdk.install2
-rw-r--r--debian/default-fonts-fc-sdk.postinst20
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs0
-rwxr-xr-xdebian/rules85
9 files changed, 137 insertions, 0 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..078e0c2
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,6 @@
+default-fonts-fc-sdk for Debian
+-------------------------------
+
+<possible notes regarding this package - if none, delete this file>
+
+ -- Minsu Han <minsu81.han@samsung.com> Thu, 09 Sep 2010 20:53:06 +0900
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..31e9bc7
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,7 @@
+default-fonts-fc-sdk (0.0.2-3) unstable; urgency=low
+
+ * Initial Version
+ * Git: pkgs/d/default-fonts-fc-sdk
+ * Tag: default-fonts-fc-sdk_0.0.2-3
+
+ -- Minsu Han <minsu81.han@samsung.com> Tue, 06 Dec 2011 18:13:06 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..7d8a0cf
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,14 @@
+Source: default-fonts-fc-sdk
+Section: misc
+Priority: extra
+Maintainer: Minsu Han <minsu81.han@samsung.com>
+Uploaders: Minsu Han <minsu81.han@samsung.com>
+Build-Depends: debhelper (>= 5)
+Standards-Version: 3.7.2
+Homepage: N/A
+
+Package: default-fonts-fc-sdk
+Section: misc
+Architecture: any
+Description: Font configuration package for fontconfig
+ This package is maintained by SDK team
diff --git a/debian/default-fonts-fc-sdk.install b/debian/default-fonts-fc-sdk.install
new file mode 100644
index 0000000..aa796c6
--- /dev/null
+++ b/debian/default-fonts-fc-sdk.install
@@ -0,0 +1,2 @@
+usr/etc/fonts/conf.d/*
+usr/etc/fonts/conf.avail/*
diff --git a/debian/default-fonts-fc-sdk.postinst b/debian/default-fonts-fc-sdk.postinst
new file mode 100644
index 0000000..d50cb31
--- /dev/null
+++ b/debian/default-fonts-fc-sdk.postinst
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+FONT_FILES="99-slp.conf"
+
+if [ ${USER} == "root" ]
+then
+ # Change file owner
+ # Font files
+ for file in `echo $FONT_FILES`
+ do
+ chown root:root /usr/etc/fonts/conf.d/$file
+ done
+fi
+
+# Font files
+for file in `echo $FONT_FILES`
+do
+ chmod 644 /usr/etc/fonts/conf.d/$file
+done
+
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/debian/docs
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f41458e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,85 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+INSTALL_DIR = $(CURDIR)/debian/tmp
+CONFIG_NAME = 99-slp.conf
+
+configure: configure-stamp
+
+configure-stamp:
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -rm -rf $(INSTALL_DIR) clean
+ -rm -rf $(CURDIR)/debian/default-fonts-fc-sdk
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/default-fonts-fc-slp.
+ mkdir -p $(INSTALL_DIR)/usr/etc/fonts/conf.d/
+ mkdir -p $(INSTALL_DIR)/usr/etc/fonts/conf.avail/ && cp -a $(CURDIR)/sdk_fonts_fc/* $(INSTALL_DIR)/usr/etc/fonts/conf.avail/
+ cd $(INSTALL_DIR)/usr/etc/fonts/conf.d/
+ ln -s ../conf.avail/$(CONFIG_NAME) $(INSTALL_DIR)/usr/etc/fonts/conf.d/$(CONFIG_NAME)
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure