summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMyoungWoon Roy Kim <myoungwoon.kim@samsung.com>2011-01-11 20:31:11 +0900
committerMyoungWoon Roy Kim <myoungwoon.kim@samsung.com>2011-01-11 20:31:11 +0900
commitc29ca657108327eb5d47b33936e10e7265135204 (patch)
treed144a8014a7c722696692516b48fba59f8bb31bc /debian
downloaddefault-fonts-fc-sdk-c29ca657108327eb5d47b33936e10e7265135204.tar.gz
default-fonts-fc-sdk-c29ca657108327eb5d47b33936e10e7265135204.tar.bz2
default-fonts-fc-sdk-c29ca657108327eb5d47b33936e10e7265135204.zip
Create font configuration package for SLPSans.
Diffstat (limited to 'debian')
-rw-r--r--debian/README.Debian6
-rw-r--r--debian/changelog7
-rw-r--r--debian/compat1
-rw-r--r--debian/control15
-rw-r--r--debian/default-fonts-fc-slp.install2
-rw-r--r--debian/default-fonts-fc-slp.postinst20
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs0
-rwxr-xr-xdebian/rules85
9 files changed, 138 insertions, 0 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644
index 0000000..772ff88
--- /dev/null
+++ b/debian/README.Debian
@@ -0,0 +1,6 @@
+default-fonts-fc-slp for Debian
+-------------------------------
+
+<possible notes regarding this package - if none, delete this file>
+
+ -- unknown <myoungwoon.kim@samsung.com> Thu, 09 Sep 2010 20:53:06 +0900
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..c84a56e
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,7 @@
+default-fonts-fc-sdk (0.0.1-1) unstable; urgency=low
+
+ * Initial release
+ * Git: 165.213.180.234:slp/sdk/default-fonts-fc-sdk
+ * Tag: default-fonts-fc-sdk_0.0.1-1
+
+ -- MyoungWoon Roy Kim <myoungwoon.kim@samsung.com> Tue, 11 Jan 2011 20:22:57 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..0227237
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,15 @@
+Source: default-fonts-fc-sdk
+Section: misc
+Priority: extra
+Maintainer: MyoungWoon Roy Kim <myoungwoon.kim@samsung.com>
+Uploaders:
+Build-Depends: debhelper (>= 5)
+Standards-Version: 3.7.2
+Homepage: N/A
+
+Package: default-fonts-fc-sdk
+Section: misc
+Architecture: any
+Depends: default-fonts-sdk
+Description: Font configuration package for fontconfig
+ This package is maintained by SDK team
diff --git a/debian/default-fonts-fc-slp.install b/debian/default-fonts-fc-slp.install
new file mode 100644
index 0000000..aa796c6
--- /dev/null
+++ b/debian/default-fonts-fc-slp.install
@@ -0,0 +1,2 @@
+usr/etc/fonts/conf.d/*
+usr/etc/fonts/conf.avail/*
diff --git a/debian/default-fonts-fc-slp.postinst b/debian/default-fonts-fc-slp.postinst
new file mode 100644
index 0000000..d50cb31
--- /dev/null
+++ b/debian/default-fonts-fc-slp.postinst
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+FONT_FILES="99-slp.conf"
+
+if [ ${USER} == "root" ]
+then
+ # Change file owner
+ # Font files
+ for file in `echo $FONT_FILES`
+ do
+ chown root:root /usr/etc/fonts/conf.d/$file
+ done
+fi
+
+# Font files
+for file in `echo $FONT_FILES`
+do
+ chmod 644 /usr/etc/fonts/conf.d/$file
+done
+
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/debian/docs
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f41458e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,85 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+INSTALL_DIR = $(CURDIR)/debian/tmp
+CONFIG_NAME = 99-slp.conf
+
+configure: configure-stamp
+
+configure-stamp:
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -rm -rf $(INSTALL_DIR) clean
+ -rm -rf $(CURDIR)/debian/default-fonts-fc-sdk
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/default-fonts-fc-slp.
+ mkdir -p $(INSTALL_DIR)/usr/etc/fonts/conf.d/
+ mkdir -p $(INSTALL_DIR)/usr/etc/fonts/conf.avail/ && cp -a $(CURDIR)/sdk_fonts_fc/* $(INSTALL_DIR)/usr/etc/fonts/conf.avail/
+ cd $(INSTALL_DIR)/usr/etc/fonts/conf.d/
+ ln -s ../conf.avail/$(CONFIG_NAME) $(INSTALL_DIR)/usr/etc/fonts/conf.d/$(CONFIG_NAME)
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure