summaryrefslogtreecommitdiff
path: root/test/pdiff/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/pdiff/Makefile.am')
-rw-r--r--test/pdiff/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/test/pdiff/Makefile.am b/test/pdiff/Makefile.am
new file mode 100644
index 000000000..73098da78
--- /dev/null
+++ b/test/pdiff/Makefile.am
@@ -0,0 +1,19 @@
+include $(top_srcdir)/build/Makefile.am.common
+
+EXTRA_PROGRAMS += perceptualdiff
+EXTRA_DIST += gpl.txt
+
+noinst_LTLIBRARIES = libpdiff.la
+libpdiff_la_SOURCES = \
+ pdiff.h \
+ lpyramid.c \
+ lpyramid.h \
+ pdiff.c
+
+perceptualdiff_SOURCES = \
+ args.c \
+ args.h \
+ perceptualdiff.c
+
+AM_CPPFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src $(CAIRO_CFLAGS)
+LDADD = libpdiff.la $(top_builddir)/src/libcairo.la