summaryrefslogtreecommitdiff
path: root/boilerplate/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'boilerplate/Makefile.am')
-rw-r--r--[-rwxr-xr-x]boilerplate/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/boilerplate/Makefile.am b/boilerplate/Makefile.am
index 29ad015ac..240736c79 100755..100644
--- a/boilerplate/Makefile.am
+++ b/boilerplate/Makefile.am
@@ -21,7 +21,7 @@ cxx_boilerplate_lib =
endif
EXTRA_LTLIBRARIES += libcairoboilerplate.la $(cxx_boilerplate_lib)
-
+#lib_LTLIBRARIES = libcairoboilerplate.la $(cxx_boilerplate_lib)
libcairoboilerplate_la_SOURCES = \
$(enabled_cairo_boilerplate_headers) \
@@ -58,6 +58,10 @@ if CAIRO_HAS_WIN32_SURFACE
libcairoboilerplate_la_LIBADD += -lwinspool
endif
+if CAIRO_HAS_CGL_FUNCTIONS
+libcairoboilerplate_la_LDFLAGS = -framework OpenGL
+endif
+
cairo-boilerplate-constructors.c: Makefile $(enabled_cairo_boilerplate_sources) $(enabled_cairo_boilerplate_cxx_sources) make-cairo-boilerplate-constructors.sh
(cd $(srcdir) && sh ./make-cairo-boilerplate-constructors.sh $(enabled_cairo_boilerplate_sources) $(enabled_cairo_boilerplate_cxx_sources)) > $@