summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--[-rwxr-xr-x]Makefile.am29
1 files changed, 13 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index 0fa9c74f4..03fa35236 100755..100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,28 +16,25 @@ EXTRA_DIST += \
ACLOCAL_AMFLAGS = -I build ${ACLOCAL_FLAGS}
-#DIST_SUBDIRS = src doc util boilerplate test
-#SUBDIRS = src doc util
-DIST_SUBDIRS = src util boilerplate
-SUBDIRS = src util
+DIST_SUBDIRS = src doc util boilerplate test perf
+SUBDIRS = src doc util
# libpng is required for our test programs
if CAIRO_HAS_PNG_FUNCTIONS
-#SUBDIRS += boilerplate test
-SUBDIRS += boilerplate
+SUBDIRS += boilerplate test perf
endif
configure: cairo-version.h
-#doc:
-# cd doc && $(MAKE) $(AM_MAKEFLAGS) $@
-#test retest recheck: all
-# cd test && $(MAKE) $(AM_MAKEFLAGS) $@
-#perf: all
-# cd perf && $(MAKE) $(AM_MAKEFLAGS) $@
-#check-valgrind: all
-# cd test && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
-# cd perf && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
-#.PHONY: doc test retest recheck perf check-valgrind
+doc:
+ cd doc && $(MAKE) $(AM_MAKEFLAGS) $@
+test retest recheck: all
+ cd test && $(MAKE) $(AM_MAKEFLAGS) $@
+perf: all
+ cd perf && $(MAKE) $(AM_MAKEFLAGS) $@
+check-valgrind: all
+ cd test && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
+ cd perf && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
+.PHONY: doc test retest recheck perf check-valgrind
EXTRA_DIST += \