summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorhk57.kim <hk57.kim@samsung.com>2016-06-30 15:54:38 +0900
committerjerry kim <hk57.kim@samsung.com>2016-06-29 23:55:35 -0700
commit0943bf528f223f9ccf2fcb15c87053f694052bfc (patch)
treef3dbf4320cacc505c00345d57bb001451dd03e47 /configure.ac
parentc279cf141e79f15eccd5ff386cf008c8cba8fb64 (diff)
downloadcairo-0943bf528f223f9ccf2fcb15c87053f694052bfc.tar.gz
cairo-0943bf528f223f9ccf2fcb15c87053f694052bfc.tar.bz2
cairo-0943bf528f223f9ccf2fcb15c87053f694052bfc.zip
By default T-trace is disabled in the build. Use --enable-ttrace=yes for enabling the same. Change-Id: I697c0a3f05bc9010620db563a4121c2ed0e46599 Signed-off-by: hk57.kim <hk57.kim@samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0d85c2fc1..ef5725fb2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,6 +50,16 @@ AC_CHECK_LIB(z, compress,
[have_libz="no (requires zlib http://www.gzip.org/zlib/)"])],
[have_libz="no (requires zlib http://www.gzip.org/zlib/)"])
+AC_CHECK_LIB(ttrace, traceBegin,
+ [AC_CHECK_HEADER(ttrace.h, [
+ have_ttrace=yes
+ AC_DEFINE(HAVE_TTRACE, 1, [Define to 1 if you have ttrace available])
+ ttrace_LIBS="-lttrace"
+ ],
+ [have_ttrace="no (requires ttrace)"])],
+ [have_ttrace="no (requires ttraec)"])
+LIBS="$ttrace_LIBS $LIBS"
+
AC_CHECK_LIB(wayland-client, wl_display_connect,
[AC_CHECK_HEADER(wayland-client.h, [
have_wayland=yes
@@ -843,6 +853,12 @@ CAIRO_ENABLE(trace, cairo-trace, auto, [
fi
])
+CAIRO_ENABLE(ttrace, cairo-ttrace, no, [
+ if test "x$have_ttrace" != "xyes"; then
+ use_ttrace="no (requires ttrace)"
+ fi
+])
+
CAIRO_ENABLE(interpreter, cairo-script-interpreter, yes, [
if test "x$have_libz" != "xyes"; then
use_interpreter="no (requires zlib)"