summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authormh0310.choi <mh0310.choi@samsung.com>2015-07-28 10:46:57 +0900
committermh0310.choi <mh0310.choi@samsung.com>2015-07-28 13:08:12 +0900
commit5e67a6f721eaedda61300baf0799199c7771ebd0 (patch)
tree6cd50b52498aab50e79b966cdccc2a137db316d9 /Makefile.am
parentd3aeffba37161d2b76b29c4ea13369bd67a47a8e (diff)
downloadcairo-5e67a6f721eaedda61300baf0799199c7771ebd0.tar.gz
cairo-5e67a6f721eaedda61300baf0799199c7771ebd0.tar.bz2
cairo-5e67a6f721eaedda61300baf0799199c7771ebd0.zip
- from 1.12.14 to 1.14.2 Change-Id: I3b62d212041b337bbb926d579f9ce74f42a45c3b
Diffstat (limited to 'Makefile.am')
-rw-r--r--[-rwxr-xr-x]Makefile.am29
1 files changed, 13 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index 0fa9c74f4..03fa35236 100755..100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,28 +16,25 @@ EXTRA_DIST += \
ACLOCAL_AMFLAGS = -I build ${ACLOCAL_FLAGS}
-#DIST_SUBDIRS = src doc util boilerplate test
-#SUBDIRS = src doc util
-DIST_SUBDIRS = src util boilerplate
-SUBDIRS = src util
+DIST_SUBDIRS = src doc util boilerplate test perf
+SUBDIRS = src doc util
# libpng is required for our test programs
if CAIRO_HAS_PNG_FUNCTIONS
-#SUBDIRS += boilerplate test
-SUBDIRS += boilerplate
+SUBDIRS += boilerplate test perf
endif
configure: cairo-version.h
-#doc:
-# cd doc && $(MAKE) $(AM_MAKEFLAGS) $@
-#test retest recheck: all
-# cd test && $(MAKE) $(AM_MAKEFLAGS) $@
-#perf: all
-# cd perf && $(MAKE) $(AM_MAKEFLAGS) $@
-#check-valgrind: all
-# cd test && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
-# cd perf && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
-#.PHONY: doc test retest recheck perf check-valgrind
+doc:
+ cd doc && $(MAKE) $(AM_MAKEFLAGS) $@
+test retest recheck: all
+ cd test && $(MAKE) $(AM_MAKEFLAGS) $@
+perf: all
+ cd perf && $(MAKE) $(AM_MAKEFLAGS) $@
+check-valgrind: all
+ cd test && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
+ cd perf && $(MAKE) $(AM_MAKEFLAGS) check-valgrind
+.PHONY: doc test retest recheck perf check-valgrind
EXTRA_DIST += \