summaryrefslogtreecommitdiff
path: root/packaging/csapi-webview.spec
diff options
context:
space:
mode:
authoryh106.jung <yh106.jung@samsung.com>2017-02-17 13:12:56 +0900
committeryh106.jung <yh106.jung@samsung.com>2017-03-17 14:39:14 +0900
commitaca675d31f77ab8373bc5487cd0ef8fc882cf831 (patch)
tree54a0f4146b2421c636c89fadfadc033d3a802bf5 /packaging/csapi-webview.spec
parentcea70b4434ca284d84beda6ecfc9639de441f499 (diff)
downloadwebview-c3fa0d2fcf75377dd55635c7e53c5d6af6c37c61.tar.gz
webview-c3fa0d2fcf75377dd55635c7e53c5d6af6c37c61.tar.bz2
webview-c3fa0d2fcf75377dd55635c7e53c5d6af6c37c61.zip
This patch introduces Tizen.WebView project. Plus, Tizen.WebView.Test project is included in order to test basic functionality of Tizen.WebView. Change-Id: I79b01c2c18817f399f83a3e56cc5cd8ceae3322f Signed-off-by: yh106.jung <yh106.jung@samsung.com>
Diffstat (limited to 'packaging/csapi-webview.spec')
-rw-r--r--packaging/csapi-webview.spec44
1 files changed, 44 insertions, 0 deletions
diff --git a/packaging/csapi-webview.spec b/packaging/csapi-webview.spec
new file mode 100644
index 0000000..d655061
--- /dev/null
+++ b/packaging/csapi-webview.spec
@@ -0,0 +1,44 @@
+Name: csapi-webview
+Summary: Tizen WebView API for C#
+Version: 1.0.0
+Release: 1
+Group: Development/Libraries
+License: Apache-2.0
+URL: https://www.tizen.org
+Source0: %{name}-%{version}.tar.gz
+Source1: %{name}.manifest
+
+AutoReqProv: no
+ExcludeArch: aarch64
+
+BuildRequires: dotnet-build-tools
+
+# C# API Requires
+BuildRequires: elm-sharp-nuget
+
+%define Assemblies Tizen.WebView
+
+%description
+%{summary}
+
+%dotnet_import_sub_packages
+
+%prep
+%setup -q
+cp %{SOURCE1} .
+
+%build
+for ASM in %{Assemblies}; do
+%dotnet_build $ASM
+%dotnet_pack $ASM/$ASM.nuspec %{version}
+done
+
+%install
+for ASM in %{Assemblies}; do
+%dotnet_install $ASM
+done
+
+%files
+%manifest %{name}.manifest
+%license LICENSE
+%attr(644,root,root) %{dotnet_assembly_files}