summaryrefslogtreecommitdiff
path: root/packaging/elm-sharp.spec
diff options
context:
space:
mode:
authorjh0506.yun <jh0506.yun@DO-JH0506-YUN03>2016-10-06 10:18:38 +0900
committerjh0506.yun <jh0506.yun@DO-JH0506-YUN03>2016-10-06 14:02:28 +0900
commitf98ede328c91b510d5a170c4972bcb29174c6d9c (patch)
treebc22aeae6bc991493c4530cfbac725ad80157a7e /packaging/elm-sharp.spec
parentd2a9771966885feeb8c598950ec8b6096931fd5a (diff)
downloadelm-sharp-f98ede328c91b510d5a170c4972bcb29174c6d9c.tar.gz
elm-sharp-f98ede328c91b510d5a170c4972bcb29174c6d9c.tar.bz2
elm-sharp-f98ede328c91b510d5a170c4972bcb29174c6d9c.zip
Add ElmSharp theme
Signed-off-by: jh0506.yun <jh0506.yun@samsung.com> Change-Id: Iaec9141c09206230cb1b6d1b66dc0b86ab7653fa
Diffstat (limited to 'packaging/elm-sharp.spec')
-rw-r--r--packaging/elm-sharp.spec7
1 files changed, 7 insertions, 0 deletions
diff --git a/packaging/elm-sharp.spec b/packaging/elm-sharp.spec
index 34f2202..a9817d5 100644
--- a/packaging/elm-sharp.spec
+++ b/packaging/elm-sharp.spec
@@ -20,6 +20,7 @@ BuildRequires: mono-compiler
BuildRequires: mono-devel
BuildRequires: dotnet-build-tools
+BuildRequires: edje-tools
%description
C# Binding for Elementary
@@ -40,6 +41,8 @@ find $ASM/*.csproj -exec xbuild {} /p:Configuration=%{BUILDCONF} \;
nuget pack $ASM/$ASM.nuspec -Version %{version} -Properties Configuration=%{BUILDCONF}
done
+edje_cc ElmSharp/theme/%{profile}/elm-sharp-theme-%{profile}.edc ElmSharp/theme/elm-sharp-theme.edj
+
%install
# Runtime Binary
mkdir -p %{buildroot}%{dotnet_assembly_path}
@@ -53,11 +56,15 @@ done
# NuGet
mkdir -p %{buildroot}/nuget
install -p -m 644 *.nupkg %{buildroot}/nuget
+# Theme
+mkdir %{buildroot}%{_datadir}/edje/elm-sharp -p
+install -m 644 ElmSharp/theme/elm-sharp-theme.edj %{buildroot}%{_datadir}/edje/elm-sharp/
%files
%manifest %{name}.manifest
%license LICENSE
%attr(644,root,root) %{dotnet_assembly_path}/*.dll
+%attr(644,root,root) %{_datadir}/edje/elm-sharp/*.edj
%package nuget
Summary: NuGet package for %{name}