summaryrefslogtreecommitdiff
path: root/packaging/syspopup.spec
diff options
context:
space:
mode:
authorMichael Leibowitz <michael.leibowitz@intel.com>2013-07-17 14:23:40 -0700
committerMichael Leibowitz <michael.leibowitz@intel.com>2013-07-17 14:23:40 -0700
commit1cd6f5ec644a9979178efcce036bd9d25209a36c (patch)
tree2913728f38aeceab899b34cc77343814287b5b8e /packaging/syspopup.spec
parent39290dcf79708e5201a82e132a4d06beb02d1d33 (diff)
downloadsyspopup-1cd6f5ec644a9979178efcce036bd9d25209a36c.tar.gz
syspopup-1cd6f5ec644a9979178efcce036bd9d25209a36c.tar.bz2
syspopup-1cd6f5ec644a9979178efcce036bd9d25209a36c.zip
Fix manifests
put manifests in packaging/ consistent use of %{name} macros Signed-off-by: Michael Leibowitz <michael.leibowitz@intel.com>
Diffstat (limited to 'packaging/syspopup.spec')
-rwxr-xr-xpackaging/syspopup.spec13
1 files changed, 8 insertions, 5 deletions
diff --git a/packaging/syspopup.spec b/packaging/syspopup.spec
index c1fb77e..d77a38e 100755
--- a/packaging/syspopup.spec
+++ b/packaging/syspopup.spec
@@ -5,7 +5,10 @@ Release: 1
Group: System/Libraries
License: Apache License, Version 2.0
Source0: syspopup-%{version}.tar.gz
-Source1001: syspopup.manifest
+Source1001: %{name}.manifest
+Source1002: %{name}-devel.manifest
+Source1003: %{name}-caller.manifest
+Source1004: %{name}-caller-devel.manifest
BuildRequires: cmake
BuildRequires: pkgconfig(sqlite3)
BuildRequires: pkgconfig(bundle)
@@ -51,7 +54,7 @@ syspopup-caller development package for popup
%prep
%setup -q
-cp %{SOURCE1001} .
+cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} .
%build
%cmake . -DEXTRA_CFLAGS=-fPIC
@@ -90,7 +93,7 @@ touch %{buildroot}%{_datadir}/popup_noti_term
%files devel
-%manifest %{name}.manifest
+%manifest %{name}-devel.manifest
%defattr(-,root,root,-)
%{_includedir}/SLP_SYSPOPUP_PG.h
%{_includedir}/syspopup.h
@@ -98,12 +101,12 @@ touch %{buildroot}%{_datadir}/popup_noti_term
%{_libdir}/pkgconfig/syspopup.pc
%files caller
-%manifest %{name}.manifest
+%manifest %{name}-caller.manifest
%defattr(-,root,root,-)
%{_libdir}/libsyspopup_caller.so.0.1.0
%files caller-devel
-%manifest %{name}.manifest
+%manifest %{name}-caller-devel.manifest
%defattr(-,root,root,-)
%{_libdir}/libsyspopup_caller.so
%{_includedir}/syspopup_caller.h