summaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authorLi,Limin <liminx.li@intel.com>2014-01-08 18:01:31 +0800
committerLi,Limin <liminx.li@intel.com>2014-01-08 18:03:38 +0800
commit3a86573c836fcbe7cb6072e5607b4216c6c5c133 (patch)
treefb2b812369b88727e6c8d2365f3a4f0d831bcbb0 /client/CMakeLists.txt
parentbc0915cd3c899263c1be54730be7df3ecb9b54dd (diff)
downloadui-gadget-1-accepted/tizen/generic/20140114.145758.tar.gz
ui-gadget-1-accepted/tizen/generic/20140114.145758.tar.bz2
ui-gadget-1-accepted/tizen/generic/20140114.145758.zip
The display server based on X or Wayland, is now a choice of different profile in Tizen 3.0. Basically and consistently, two macros were used "with wayland" and "with x". Below summarize the combination of the macros: | wayland | x | meaning |--------------------------- | 0 | 1 | pure X11 platform(no wayland) | 1 | 0 | pure wayland platform (no X11) | 1 | 1 | wayland but X compatibility | 0 | 0 | no X and no wayland This method unifies the meaning and usage. Deploy this method to ui-gadget package. Signed-off-by: Li,Limin <liminx.li@intel.com> Change-Id: Iceb95b03f824860b2aac74f35c0945380f6cc22a
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--[-rwxr-xr-x]client/CMakeLists.txt21
1 files changed, 9 insertions, 12 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index cd31296..35f00af 100755..100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -7,18 +7,15 @@ SET(CLIENT_LOCALEDIR /usr/share/locale)
INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
INCLUDE(FindPkgConfig)
-PKG_CHECK_MODULES(CLIENT_PKGS REQUIRED
- capi-appfw-application
- capi-system-runtime-info
- appcore-efl
- appsvc
- bundle
- ecore-x
- edje
- dlog
- elementary
- evas
- x11)
+SET(CLIENT_PKGS_CHECK_MODULES "capi-appfw-application capi-system-runtime-info appcore-efl appsvc bundle edje dlog elementary evas")
+
+IF (with_x)
+ PKG_CHECK_MODULES(CLIENT_PKGS REQUIRED ${CLIENT_PKGS_CHECK_MODULES} ecore-x x11)
+ENDIF(with_x)
+
+IF (with_wayland)
+ PKG_CHECK_MODULES(CLIENT_PKGS REQUIRED ${CLIENT_PKGS_CHECK_MODULES})
+ENDIF(with_wayland)
FOREACH(flag ${CLIENT_PKGS_CFLAGS})
SET(CLIENT_CFLAGS "${CLIENT_CFLAGS} ${flag}")