summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLi,Limin <liminx.li@intel.com>2014-01-08 18:01:31 +0800
committerLi,Limin <liminx.li@intel.com>2014-01-08 18:03:38 +0800
commit3a86573c836fcbe7cb6072e5607b4216c6c5c133 (patch)
treefb2b812369b88727e6c8d2365f3a4f0d831bcbb0 /CMakeLists.txt
parentbc0915cd3c899263c1be54730be7df3ecb9b54dd (diff)
downloadui-gadget-1-3a86573c836fcbe7cb6072e5607b4216c6c5c133.tar.gz
ui-gadget-1-3a86573c836fcbe7cb6072e5607b4216c6c5c133.tar.bz2
ui-gadget-1-3a86573c836fcbe7cb6072e5607b4216c6c5c133.zip
The display server based on X or Wayland, is now a choice of different profile in Tizen 3.0. Basically and consistently, two macros were used "with wayland" and "with x". Below summarize the combination of the macros: | wayland | x | meaning |--------------------------- | 0 | 1 | pure X11 platform(no wayland) | 1 | 0 | pure wayland platform (no X11) | 1 | 1 | wayland but X compatibility | 0 | 0 | no X and no wayland This method unifies the meaning and usage. Deploy this method to ui-gadget package. Signed-off-by: Li,Limin <liminx.li@intel.com> Change-Id: Iceb95b03f824860b2aac74f35c0945380f6cc22a
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--[-rwxr-xr-x]CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d8dbba..7733cdf 100755..100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,16 @@ SET(SRCS src/ug.c
ADD_LIBRARY(${PROJECT_NAME} SHARED ${SRCS})
-PKG_CHECK_MODULES(PKGS REQUIRED glib-2.0 utilX bundle dlog x11 capi-appfw-application appsvc capi-appfw-app-manager ecore)
+SET(PKGS_CHECK_MODULES "glib-2.0 bundle dlog capi-appfw-application appsvc capi-appfw-app-manager ecore")
+IF (with_x)
+ PKG_CHECK_MODULES(PKGS REQUIRED ${PKGS_CHECK_MODULES} utilX x11)
+ENDIF(with_x)
+
+IF (with_wayland)
+ ADD_DEFINITIONS("-DWAYLAND")
+ PKG_CHECK_MODULES(PKGS REQUIRED ${PKGS_CHECK_MODULES})
+ENDIF (with_wayland)
+
FOREACH(flag ${PKGS_CFLAGS})
SET(CFLAGS "${CFLAGS} ${flag}")
ENDFOREACH(flag)