summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFabio Mello <fabio.mello@intel.com>2014-02-14 10:35:57 -0200
committerSemun Lee <sm79.lee@samsung.com>2014-03-07 13:56:03 +0900
commit084d912cb688c5a9257b3446b2f5f40260d16c6f (patch)
tree313e9ac9cb29eec80883f89781e62553d40e920d /CMakeLists.txt
parent92210284ef62357b7a08fbd973d291ee1afe04ec (diff)
downloadui-gadget-1-084d912cb688c5a9257b3446b2f5f40260d16c6f.tar.gz
ui-gadget-1-084d912cb688c5a9257b3446b2f5f40260d16c6f.tar.bz2
ui-gadget-1-084d912cb688c5a9257b3446b2f5f40260d16c6f.zip
Apps should not require ecore_x.
The current UG_INIT_EFL() macro forces the applications who uses it to depend on ecore_x. This patch uses a higher level of abstraction in this macro, this approach lets ui-gadget-1 handle the display server without expose this to its dependents. Signed-off-by: Leandro Dorileo <leandro.maciel.dorileo@intel.com> Signed-off-by: Fabio Mello <fabio.mello@intel.com> Conflicts: CMakeLists.txt Change-Id: I9a1683df1ee64b2d997b0edfedc6bfc695aed9e7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c665300..ed72a99 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,7 @@ SET(SRCS src/ug.c
ADD_LIBRARY(${PROJECT_NAME} SHARED ${SRCS})
-SET(PKGS_CHECK_MODULES "glib-2.0 bundle dlog capi-appfw-application appsvc capi-appfw-app-manager ecore libtzplatform-config")
+SET(PKGS_CHECK_MODULES "glib-2.0 bundle dlog capi-appfw-application appsvc capi-appfw-app-manager ecore elementary libtzplatform-config")
IF (with_x)
PKG_CHECK_MODULES(PKGS REQUIRED ${PKGS_CHECK_MODULES} utilX x11)
ENDIF(with_x)