summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJiwoong Im <jiwoong.im@samsung.com>2017-04-28 13:51:24 +0900
committerJiwoong Im <jiwoong.im@samsung.com>2017-04-28 04:52:32 +0000
commitc1383a9d34d47837503a61ba5affda841156c4eb (patch)
tree579805c55f7a9b4d7ec1062b12f7efaf161ae318 /CMakeLists.txt
parentb56e38982040fdf884db7c19f7d3bd490d8ec118 (diff)
downloadui-gadget-1-c1383a9d34d47837503a61ba5affda841156c4eb.tar.gz
ui-gadget-1-c1383a9d34d47837503a61ba5affda841156c4eb.tar.bz2
ui-gadget-1-c1383a9d34d47837503a61ba5affda841156c4eb.zip
Loading library with absolute path
- Loading libraries without specifying an absolute path could allow an attacker to load a malicious library by changing $LD_* or other aspects of the program's execution environment. Change-Id: Ic51469d1ffab14008e8ef550ae604ee7f3138994 Signed-off-by: Jiwoong Im <jiwoong.im@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eb774bb..69662f0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,7 @@ INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/include)
ADD_DEFINITIONS("-DPREFIX=\"${CMAKE_INSTALL_PREFIX}\"")
ADD_DEFINITIONS("-DDATAFS=\"${DATADIR}\"")
ADD_DEFINITIONS("-DENABLE_UG_CREATE_CB")
+ADD_DEFINITIONS("-DUG_LIB_DIR=\"${LIB_INSTALL_DIR}\"")
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fvisibility=hidden -Wall")
INCLUDE(FindPkgConfig)