summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKibum Kim <kb0929.kim@samsung.com>2012-02-27 21:16:17 +0900
committerKibum Kim <kb0929.kim@samsung.com>2012-02-27 21:16:17 +0900
commit213d4ec9d2c728d50d110e4c6cc7247344319499 (patch)
treebf8a903acacc68a191e68eda8da58676ea596ac3 /debian
downloadheynoti-213d4ec9d2c728d50d110e4c6cc7247344319499.tar.gz
heynoti-213d4ec9d2c728d50d110e4c6cc7247344319499.tar.bz2
heynoti-213d4ec9d2c728d50d110e4c6cc7247344319499.zip
tizen beta release
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/changelog7
-rw-r--r--debian/compat1
-rwxr-xr-xdebian/control33
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs1
-rw-r--r--debian/libheynoti-0.install.in2
-rwxr-xr-xdebian/libheynoti-0.postinst.in5
-rw-r--r--debian/libheynoti-dev.install.in3
-rwxr-xr-xdebian/rules122
9 files changed, 176 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100755
index 0000000..120e6cc
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,7 @@
+heynoti (0.0.2-32) unstable; urgency=low
+
+ * Initial Release.
+ * Git: pkgs/h/heynoti
+ * Tag: heynoti_0.0.2-32
+
+ -- Sewook Park <sewook7.park@samsung.com> Wed, 07 Dec 2011 12:55:49 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100755
index 0000000..e0effde
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,33 @@
+Source: heynoti
+Section: libs
+Priority: extra
+Maintainer: Jayoun Lee <airjany@samsung.com>, Sewook Park <sewook7.park@samsung.com>, Jaeho Lee <jaeho81.lee@samsung.com>
+Uploaders: Youmin Ha <youmin.ha@samsung.com>, Noha Park <noha.park@samsung.com>, Sangjung Woo <sangjung.woo@samsung.com>
+Build-Depends: debhelper (>= 5), dlog-dev, libglib2.0-dev
+Standards-Version: 3.7.2
+Homepage: N/A
+
+Package: libheynoti-dev
+Section: libs
+Architecture: any
+Depends: libheynoti-0 (= ${Source-Version}), libglib2.0-dev
+Description: heynoti notification library (development)
+ HEY(ligHt Easy speedY) notification library.
+ This includes notify service APIs.
+XB-Generate-Docs: yes
+
+Package: libheynoti-0
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: heynoti notification library (shared object)
+ HEY(ligHt Easy speedY) notification library.
+ This includes notify service APIs.
+
+Package: libheynoti-dbg
+Section: debug
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, libheynoti-0 (= ${Source-Version})
+Description: heynoti notification library (unstripped)
+ HEY(ligHt Easy speedY) notification library.
+ This includes notify service APIs.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..a0f0008
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+CMakeLists.txt
diff --git a/debian/libheynoti-0.install.in b/debian/libheynoti-0.install.in
new file mode 100644
index 0000000..9c4dbc5
--- /dev/null
+++ b/debian/libheynoti-0.install.in
@@ -0,0 +1,2 @@
+@PREFIX@/lib/lib*.so.*
+@PREFIX@/bin/heynotitool
diff --git a/debian/libheynoti-0.postinst.in b/debian/libheynoti-0.postinst.in
new file mode 100755
index 0000000..d382f2c
--- /dev/null
+++ b/debian/libheynoti-0.postinst.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+# Create directory permission
+mkdir -p /opt/share/noti
+chmod 1755 /opt/share/noti
diff --git a/debian/libheynoti-dev.install.in b/debian/libheynoti-dev.install.in
new file mode 100644
index 0000000..e236dba
--- /dev/null
+++ b/debian/libheynoti-dev.install.in
@@ -0,0 +1,3 @@
+@PREFIX@/include/heynoti/*
+@PREFIX@/lib/lib*.so
+@PREFIX@/lib/pkgconfig/*.pc
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..c3b9afe
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,122 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_GNU_OS)
+
+CFLAGS ?= -Wall -g
+CXXFLAGS ?= -Wall -g
+LDFLAGS ?=
+PREFIX ?= /usr
+DATADIR ?= /opt
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+ CXXFLAGS += -O0
+else
+ CFLAGS += -O2
+ CXXFLAGS += -O2
+endif
+
+LDFLAGS += -Wl,--rpath=$(PREFIX)/lib -Wl,--as-needed
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" cmake . -DCMAKE_INSTALL_PREFIX=$(PREFIX) -DCMAKE_BUILD_TYPE="Debug"
+
+ touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+ #docbook-to-man debian/wavplayer.sgml > wavplayer.1
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ cat $$f > $${f%.in}; \
+ sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
+ sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
+ done
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+ rm -rf CMakeCache.txt CMakeFiles cmake_install.cmake Makefile install_manifest.txt
+ cd test; rm -rf CMakeCache.txt CMakeFiles cmake_install.cmake Makefile install_manifest.txt
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ rm -f $${f%.in}; \
+ done
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/wavplayer.
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip --dbg-package=libheynoti-dbg
+ dh_compress
+ dh_fixperms
+# dh_perl
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure